flutter 包管理

使用配置文件 pubspec.yaml 来进行包管理

官方包管理的网站在 https://pub.dartlang.org/ , 可以用这个来搜索各种包. 注意看这个包有没有用 flutter 的标签.

install

每个包都有 install 的说明, 照着做就好.

english_words: ^3.1.5

添加到pubspec.yaml

在需要使用的代码那里引入: import 'package:english_words/english_words.dart';

有点奇怪的是包的名字空间怎么隔离的? 引入了 english_words.dart 后, 可以用 WordPair 这个 class, 但是如果另外一个库也有一个 class 叫 WordPair 怎么办? dart 的代码库导入